How to force a specific version of php on linux: Let's say you want to force the linux machine to use php 7.2 specifically Do this: sudo add-apt-repository -y ppa:ondrej/php sudo apt-get install php7.2 php7.2-cli php7.2-common now tell apache: sudo a2dismod php5.6 sudo a2enmod php7.2 sudo service apache2 restart now tell bash: sudo update-alternatives --set php /usr/bin/php7.2 sudo update-alternatives --set phar /usr/bin/phar7.2 sudo update-alternatives --set phar.phar /usr/bin/phar.phar7.2
Announcing the development of BirdPress(tm) I have decided to write a replacement for WordPress because I am tired of cleaning out security compromises and trying to hack .htaccess files and installing 20 plugins to just get a usable website that then weighs in at 100 MB. www.birdpress.org
If you find that going to your URL works (DNS resolves), but it shows the wrong site on your server (your default site, alphabetically, from /var/www/), and, letsencrypt says no such site, and, a2enablesite says, no such site... then it's quite simple. The config file is missing or wrong in /etc/apache2/ Possible problems: 1. Wrong permissions on the config file. 2. The config file is in sites-available but not sites-enabled 3. The config file is in sites-enabled but not sites-available 4. The config file does not have a filename ending in . conf (really!!!) 5. The folder containing HTML does not match the path given in the config file (/var/www/mysite) If apache won't start at all 1. Your syntax in the config file is wrong. It should look like this (assuming your site is mysite.co.za) : <VirtualHost *:80> DocumentRoot /var/www/mysite Options All Indexes ExecCGI ServerName www.mysite.co.za ServerAlias mysite.co.za ErrorDocument 404 /error.html </VirtualHost> <Vi...